@Friendica Support I'm logged into my server running Friendica 2022.10 over ssh, trying to start the worker daemon manually.

$ cd web/
$ php bin/daemon.php

The only output I get is:
Starting worker daemon.
But the daemon silently fails with error code 255, no pidfile is created and no tasks are performed until I run
$ php bin/worker.php
which runs normally. My error logs show nothing out of the ordinary related to the daemon. Is there another log I'm missing? Is there a way to get more verbose output from the daemon to determine what is causing the error? FOr now I have added a cron job that successfully runs worker.php, but I did want the daemon running instead. Thanks for any help.
Planet earth
2 people reshared this
Solved my own problem with this one. I enabled debugging in my admin panel and created the log file at log/friendica.log. It logged the error as a call to the undefined function pcntl_fork, which I traced to it being disabled in /etc/php/8.0/cli/php.ini. So I just took pcntl_fork out of the list of disabled functions and started the daemon again. It then stopped running with an undefined call to pcntl_waitpid, so I enabled that function in the same way and all seems to be running smoothly now, or at least it has been running for at least 5 minutes without any fatal errors. I'll keep monitoring this one, but it looks good for now.
Friendica Support reshared this.
The same process is still running, so I can say with confidence that this one is resolved. I don't recall those functions being disabled for the command line php in previous versions, but fortunately it wasn't hard to fix once I caught it.
Friendica Support reshared this.
Hypolite Petovan friendica (via ActivityPub)
Good job on finding the problem and solving it!
Friendica Support reshared this.

This website uses cookies to offer a satisfactory user experience and full functionality. By using this site, you agree to have our cookies placed on your device.